Skip to main content

1044ShoppinginMars二分

·526 words·3 mins
WFUing
Author
WFUing
A graduate who loves coding.
Table of Contents

1044 Shopping in Mars
#

0、题目
#

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

  • Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).+ Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).+ Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:
#

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤105), the total number of diamonds on the chain, and M (≤108), the amount that the customer has to pay. Then the next line contains N positive numbers D1⋯D**N (D**i≤103 for all i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:
#

For each test case, print i-j in a line for each pair of ij such that Di + … + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output i-j for pairs of ij such that Di + … + Dj >M with (Di + … + DjM) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:
#

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:
#

1-5
4-6
7-8
11-11

Sample Input 2:
#

5 13
2 4 5 7 9

Sample Output 2:
#

2-4
4-5

1、大致题意
#

求一串的数字中连续的一段,使得这个连续的段内数字的和恰好等于所期望的值m。如果不能找到恰好等于,就找让自己付出最少的价格(总和必须大于等于所给值)的那段区间,求所有可能的结果

2、基本思路
#

首先二分查找合适的价格,然后遍历一遍即可。

3、AC代码
#

#include<iostream>
using namespace std;
int n,m;
int a[1000005];

bool judge(int ans) {
	int summ=0,pre=1;
	for(int i=1; i<=n; i++) {
		summ+=a[i];
		while(summ>ans) {
			summ-=a[pre];
			pre++;
		}
		if(summ>=m&&summ<=ans) {
			return true;
		}
	}
	return false;
}

int main() {
	cin>>n>>m;
	for(int i=1; i<=n; i++) {
		cin>>a[i];
	}
	//二分
	int l=0,r=2000000008,mid,ans;
	while(l<=r) {
		int mid=(l+r)/2;
		if(judge(mid)) {
			ans=mid; //记录可行解
			r=mid-1;
		} else {
			l=mid+1;
		}

	}
//	cout<<ans<<endl;
	//查找
	int summ=0,pre=1;
	for(int i=1; i<=n; i++) {
		summ+=a[i];
		while(summ>ans) {
			summ-=a[pre];
			pre++;
		}
		if(summ==ans) {
			cout<<pre<<"-"<<i<<endl;
		} else if(summ<ans) {
			continue;
		}
	}
	return 0;
}

./figures/fe3fa1e4b9ed43e1b7fd5f6b181b20df.png