Skip to main content

1031HelloWorldforU

·346 words·2 mins
WFUing
Author
WFUing
A graduate who loves coding.
Table of Contents

1031 Hello World for U
#

0、题目
#

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible – that is, it must be satisfied that n1=n3=max { k | k≤n2 for all 3≤n2≤N } with n1+n2+n3−2=N.

Input Specification:
#

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:
#

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:
#

helloworld!

Sample Output:
#

h   !
e   d
l   l
lowor

1、大致题意
#

用所给字符串按U型输出。n1和n3是左右两条竖线从上到下的字符个数,n2是底部横线从左到右的字符个数。并满足一下要求:

  • n1 == n3+ n2 >= n1+ n1为在满足上述条件的情况下的最大值

2、基本思路
#

分三种情况讨论:

  • 如果 $n % 3 == 0$ ,直接 $n1 = n2 = n3$+ 如果 $n % 3 == 1$,因为 $n2$ 要比 $n1$ 大,所以把多出来的那1个给 $n2$+ 如果 $n % 3 == 2$,就把多出来的那2个给$n2$

所以得到公式:n1 = n / 3,n2 = n / 3 + n % 3

把它们存储到二维字符数组中,一开始初始化字符数组为空格,然后按照u型填充进去,最后输出这个数组u。

3、AC代码
#

#include <iostream>
#include <string.h>
using namespace std;
int main() {
    char c[81], u[30][30];
    memset(u, ' ', sizeof(u));
    scanf("%s", c);
    int n = strlen(c) + 2;
    int n1 = n / 3, n2 = n / 3 + n % 3, index = 0;
    for(int i = 0; i < n1; i++) u[i][0] = c[index++];
    for(int i = 1; i <= n2 - 2; i++) u[n1-1][i] = c[index++];
    for(int i = n1 - 1; i >= 0; i--) u[i][n2-1] = c[index++];
    for(int i = 0; i < n1; i++) {
        for(int j = 0; j < n2; j++) 
            printf("%c", u[i][j]);
        printf("\n");
    }
    return 0;
}